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Microsoft Excel: Macros


I. Introduction
· Introductions
· Housekeeping


II. Class Learning Objectives
By the end of this class, you will be able to:
· Understand what a macro is and what it does.
· Record a macro.
· Run the macro, in current worksheet and another worksheet.
· Change a macro to a relative reference.
· Edit a Macro.
· Open a macro in VBA editing mode.

Activity: Open “Excel-Macros_class_file” from the desktop.


III. Vocabulary 

It’s important to understand what a macro is and does. 

· Ribbon and Tabs
· Home Tab – where your most frequently accessed features are.
· View Tab – where you can organize how a page prints and record macros.
· Workbook and Worksheet
· Workbook - made up of one or more worksheets. It is the actual file.
· Worksheet – individual sheets in workbook. Accessed through the tabs at the bottom of the workbook.
· What is a macro?
· A macro is a series of recorded actions that you can then apply to other locations.
· Think about hot key combinations.
·  They are shortcuts to make your job easier and you faster at using the computer. 
· Think about some hot key combinations you already know and what they do.
· Hot keys are shortcuts for actions you would otherwise do buy clicking a button.
· Macros function in the same way: 
· You run a key combination to perform a series of actions you would otherwise do by clicking buttons.

· Why would you use a macro?
· If you need to apply the same changes to a series of workbooks or in different places within a single workbook.
· Using a computer means you shouldn’t have to repeat yourself. If you’re doing to same task over and over, think about trying to use a macro.
· We are working with macros in Excel today, but they work the exact same way in Word & PowerPoint and many other applications.


IV. Record a Basic Macro
Content: 

· We will start by recording a macro that will apply several formatting changes to the worksheets.
· In this example, we want to:
· Merge Cells A1 – D1
· Make the text bolded and size 26.
· We will apply this to several worksheets, so
· We are going to record a macro on the first one
· Use the macro to apply the same template to the other worksheets

Activity:
1. Open the 2011 worksheet.
2. Click on the Macros arrow on the View tab.
a. The Macro button is actually two different buttons. 
b. If you click on the image, it will take you to a list of all previously recorded macros.
3. Click on Record Macro.
4. Name the macro, for this class, we will call it FormatTitle.
a. Point out that you cannot leave spaces between the words in macro names.
5. Set a shortcut key.
a. We’ve already discussed hotkeys; this is the hotkey to run this macro.
b. When you assign a shortcut for your Macro, make sure not to use a combination you use for something else. If you make the macro CTRL + c, you lose the shortcut for copy and will probably end up accidentally running the macro at some point.
c. For the sake of this class, we are going to use CTRL + q.
6. Give the macro a description for people accessing it in the future. In this case, record the changes we are going to make to our workbook (e.g. merge cells…)
7. Click on OK.
Remember: Do not click on anything unnecessarily before you click on okay. The macro will record our every movement. If we make a change, it will be part of the macro. 



8. Record the macro.
a. Merge Cells A1 – D1.
b. Make the text bold.
c. Then make the text size 26.
9. Click on Macros on the View tab.
10. Click on Stop Recording. We just created our very first macro!


V. Run the Macro on another Worksheet 
· Now that we’ve recorded the macro, we can run it on any worksheet we want.
· Before we begin, when you run a macro, it becomes permanent in the workbook. 
· There is no undo. 
· The only way to fix something a macro screwed up is by hand. 
· I would recommend always saving a copy of the workbook to test your macro before you run it just to make sure you don’t mess up your data.

Activity: 
1. Click on the File tab.
2. Click on Save As…
3. Double-click on Desktop.
4. Click on the Save as Type menu.
5. Click on Excel Macro-Enabled Workbook.
6. Click on Save.


VI. Record another Macro (with cooler features)

Activity:
1. Open the 2011 worksheet.
2. Click on the Macros arrow on the View tab.
3. Click on Record Macro.
4. Name the macro AwesomeFormatting
5. Set a shortcut key to CTRL + w.
6. (Optional) Give the macro a description for people accessing it in the future.
7. Click on OK.
· Teacher’s Tip: Remind students that once we click OK, we’re in recording mode and every action performed in the spreadsheet gets recorded.
8. Record the macro.
· Make columns A – D fit all of their text.
· Make all of our number values show up as Currency.
· Make the months and store names have a green background and white text.
· Make the number values have a grey background with white text.
9. Click on Macros on the View tab.
10. Click on Stop Recording.


VII. Run the Macro on another Worksheet
Activity: 
Open the 2012 worksheet.
1. Type in CTRL + w to run the macro.
· Teacher’s Tip: Remind students that this is the shortcut key we assigned to the macro before we recorded it.
2. Open the 2013 worksheet.
3. Type in CTRL + w to run the macro.
· Point out that the macro applied the formatting to the same cells as the other worksheets, not to the cells we would like them to have adjusted. We will address this later when we talk about absolute v. relative references. 
· Press CTRL + Z to undo. Psych! You cannot undo the actions of a macro.
4. Select the range of cells from A6 – D19.
5. Drag the cells up to cell A4.
6. Run the macro again by pressing CTRL + w. That’s much better!


VIII. Absolute v. Relative References
Contents:
· There are two ways that Excel knows how to record the actions inside a macro: 
1. Absolute references
2. Relative references
· Here’s one way to think about the difference between the two. Imagine you’re running a movie theatre and you’ve programmed a robot to clean the aisles of popcorn and spilled soda. Your instructions are, “Hey Mr. Robot, go to row 1 and clean that row.” It goes to Row 1 and cleans as instructed. Once finished, you pick it up, place it in Row 2, and tell it to clean the row. It goes back to Row 1 and starts cleaning. What the heck?! That’s because it was programmed using absolute references. 
· Now imagine you re-program it, this time using relative reference mode. Your instructions are, “Hey Mr. Robot, whichever row you’re in, go clean that row.” You pick it up, place it in Row 2, and tell it to start cleaning. It cleans Row 2. Mission accomplished.
· The default when you record a macro is to run as an absolute reference. 
· So, when you select cell A1, Excel sees cell A1. When you run the macro, it will apply whatever changes you made in cell A1 to cell A1, no matter what cell you have selected.
· If you change your macro to record as a relative reference, when you click in cell A1 and make your changes the macro records what the changes are, not the cell address. Then, if you click in cell D3, when you run the macro, those changes are applied to D3 (or whatever cell you have selected).
· The same thing will apply to ranges of cells. By default, if you select A1 – D3, Excel will apply the macro to A1 – D3 on every worksheet you run the macro on. If you set it for relative references, you can record the macro in A1 – D3, but apply the macro to A4 – D6.
· We discuss on absolute vs. relative references in our Microsoft Excel: Intermediate class.

Activity:  Record a relative reference macro.
1. Go back to the 2011 worksheet.
2. Click into cell A17.
3. Click on Macros on the View tab.
4. Click on Use Relative References.
5. Click on Macros on the View tab.
6. Click on Record Macro.
7. Fill in the dialog box. Call the macro StatsReporting, and use CTRL + m for the shortcut key.
8. Type in “Total” for A17.
9. Insert an AutoSum in B17 and autofill across to D17. 
10. Type “Average” in A18.
11. Insert the Average function in cell B18 for cells B5:B16 and autofill across.
12. Click on Macros on the View tab.
13. Click on Stop Recording.

Activity: Run the macro on another worksheet.
1. Open the 2012 worksheet. 
2. Click on cell A17.
a. Because we recorded this using relative references, we need to click in the cell we want our Autosum (the first action of our macro) to appear in BEFORE we run the macro.
3. Type CTRL + m.
a. What happens when we click in the wrong cell before running our macro?
4. Open the 2013 worksheet. 
5. Click in cell B15 (the wrong starting cell).
6. Type in CTRL + m.
a. Point out that the formulas turn out wrong. This is because the macro was started from cell B15 instead of B17.
b. Point out that to correct the errors that were made with this macro, you have to fix everything by hand. We can’t just undo. 
c. Remind students that this is why we always save a copy of our work and test new macros on copies instead.
7. Open the 2014 worksheet.
8. Click in cell A19.
9. Type in CTRL + m.
a. Point out that even though the sheet was not set up the same, the macro did what it was supposed to.
b. Because of relative references! It performed the functions we asked it to relative to the cell we started running the macro in.
IX. Edit a Macro 
Contents:
· For simple edits, you can edit a macro in VBA.
· For multiple changes to your macro, it is easiest to delete it and re-record it.
· In this case, we will change the macro so the font size is 18, instead of 26.

Activity: Edit the FormatTitle macro.
· Click on Macros on the View tab.
· Click on View Macros.
· Click on the FormatTitle macro.
· Click on Edit.
· The interface that opens is VBA. You can learn to code VBA if you choose to do so. Check out the VBA Programming in Excel classes.
· Find the line for font size and change the value to 18.
· Click Save to save the changes.
· Close out of the VBA interface.
· Changing the macro doesn’t apply any changes to the workbook.
· Type CTRL + q to rerun the macro.

· Comprehension Check: Delete the StatsReporting macro.
· Click on Macros on the View tab.
· Click on View Macros.
· Click on StatsReporting.
· Click on Delete.


X. Opening a Macro-Enabled Workbook 
Contents:
· You can find macros created by other people online.
· Beware of downloading macros from the internet. They can and have been used to put malicious software onto unsuspecting computers. 
· Make sure you only download macros from reputable sources. 
· Office. Microsoft.com
· IT people in the office you work in.
· Because macros can be dangerous, when you save a workbook as a macro-enabled workbook, you have to enable macros to run them the next time you open it.

Activity: Open and enable macros in the workbook.
· Save the workbook by clicking the save icon and close out of it.
· Point out that the macro-enabled workbook icon has an exclamation point over it. This just indicates the type of workbook it is.
· Double click on the saved workbook.
· Click on the Enable this Content button in the security warning at the top.
Teacher’s Tip:
· It can help to start a new sheet and show that CTRL + q doesn’t change the document.
· Once you enable macros, type CTRL + q and see the formatting changes applied to the sheet.


XI. Help
· Use the Help Button to look for instructions for macros. 
· Perform a Google video search for macros.
· Use Lynda Library to learn more about macros and using VBA.
IV. 
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V. Wrap Up

· Any last minute questions?

· Access additional learning resources at our Technology Education webpage: www.vbgov.com/tech-ed (Also under Adults) 

· Lynda.com demonstration
· Go to VBPL website: www.VBgov.com/libraries -> Find Materials -> Research & Articles -> A to Z Resources
· Scroll down and click on Lynda.com
· Enter library card number and pin number into appropriate boxes
· Explain that students will need to finish account setup with their name and email address
· Locate Search bar across top of page and enter subject
· Notice list of suggested courses in middle of page with course descriptions and related courses tab
· Use filter options on the left side of page to narrow results by skill level and subject 
· Use + button to add courses to your playlist

· Homework – if you would like to practice your new skills, play around with one of the templates in the File tab of the ribbon. You could download and work on an inventory list, shopping list, or a to-do list.

· Google search – for text-based or video instructions
· Go to Google.com 
· Type in the appropriate terms – for example: format cell excel 2013

· Remember to check our online calendar of upcoming classes 

· For assistance with specific projects, please consider scheduling a Tech Help session through your local library branch, if available.

· Please take a few moments to complete the evaluation. Your valuable input helps us improve these classes.

Thank you for coming!
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